Home Email / About RSS feed

Vista + Intel Wireless 3945ABG = No

One of the first things I did with my laptop was to remove Window XP Home since it’s about as much use as a chocolate fire guard and install Beta 2 of Vista x64 (yeah I know RC2 is out but I don’t have a copy to hand). So I did a fresh install, deleting the existing drive partitions (Dell had configured the 80GB drive with two 30ish size ones?) and creating a new one that filled the drive.

The Vista installation then tried it damndest to grind the hard drive into a fine powder and also gave the DVD drive a good work out as well. It was a hideously slow process at over an hour, but I must admit it was slightly more stream lined than the XP installation process. You entered almost all the required details at the beginning and then it got on with it.

Once into Vista I had a quick poke around (Aero Glass is really nice and the new UI in general looks really cool) but was disappointed that it couldn’t find any drivers for the majority of the hardware in the machine. 

I did a bit of manual searching and found a video driver for the Intel GMA 950, but I couldn’t get a wireless driver, which was a bit of deal breaker since that’s my main network connection at home. There is a section on the Intel site for it, but it just sends you round in circles. Wireless drivers aren’t expected until 4th Quarter 2006… err?

It’s also amusing because last week Dell updated a lot of their range last week noting that machines were Vista Capable and in fact this laptop has the following sticker on it:

VistaCapable

At the moment, it clearly isn’t. So I switched to Windows XP x64 and had similar problems with drivers. Intel did have a 64–bit graphics and wireless driver, but for things like the sound card and memory card reader I had no joy.

I also checked the Dell site for what drivers they have for the Inspiron 640m and was out of luck for anything other than Windows XP x86, which is really poor given the Core 2 is a 64–bit processor. You’d think proper drivers would be available!

James said,

February 9, 2007 @ 1:45 pm

Same problem here. Asus A7J. Running retail release of Vista Home Premium. Wireless card kapput. Wireless on off hardware switch doesn’t do nothing. No wireless. Give me a buzz if you got a fix.

Paul said,

February 12, 2007 @ 11:32 am

Will do. Might be a while though before I try Vista again. The driver support just isn’t there atm.

Adam said,

August 16, 2007 @ 3:06 pm

Hi,
I’m trying to get the A7J to work with Vista, and I’m runing into the same problem. Did you guys manage to get it to work in the end???

Thanks

Paul said,

September 5, 2007 @ 10:46 pm

Sorry Adam but I no longer have that laptop. However in a bid to be somewhat helpful to yourself and visitors, there does now appear to be Vista drivers on the Intel site.

Info here.
Download here.

RSS feed for comments on this post · TrackBack URI

Leave a Comment